in Wordpress Themes by magicalwonders (1.9k points)
I'm trying to remove the link "Leave a Reply" that shows underneath the extract of content returned by carrying out a search.

An example can be seen on this page -

I'm not 100% sure, but I think the link is being referenced in functions.php I can't find it anywhere else.

There are two instances of it though as in the code below, and I'm not sure which one to comment out?
'title_reply'          => __( 'Leave a Reply',CURRENT_THEME ),
'title_reply_to'       => __( 'Leave a Reply to %s',CURRENT_THEME ),

Hopefully someone can advise?

6 Answers

by sarah (15.2k points)
To remove the Leave a reply link, please go to
Wordpress admin -> Pages -> Edit About page -> Click Screen options -> Check discussion -> After content, you find two check boxes of
1) Allow comments.
2) Allow trackbacks and pingbacks on this page.

please uncheck them and update.
by magicalwonders (1.9k points)
Thanks for your assistance.

I still want to enable comments on posts though. Is there not a way to remove "Leave a reply" link on just the search results page? It seems a strange link to have on that page.
by magicalwonders (1.9k points)
Sorry, I didn't read your post properly! Ignore my last message! :)
by magicalwonders (1.9k points)
I've run into a bit of a snag. I've navigated to - Edit About page -> Click Screen options -> - But I only have the following boxes -

Revisions - Custom fields - Discussion - Comments - Slug - Authour - Page Attributes - Featured Image - Theme options.

I have ticked the Discussion box, and the comment box was already blank. It deosn't seem to have impacted on the search page though?

The boxes that were already ticked are - Revisions - Page Attributes - Featured Image - Theme options

I'm running WP 3.9.1 and I've attached a screenshot to show you what I am seeing.

by sarah (15.2k points)
In screen options after ticking the discussion box, the two checkboxes will appear after the content. These two are :
1) Allow comments.
2) Allow trackbacks and pingbacks on this page.

Please uncheck them and update the page. It will work. If still problem exists, then please open a support ticket at
by magicalwonders (1.9k points)
OK I understand now. I was looking for the check boxes for comments and trackbacks in the screen options!

Thanks for the help. :)
Interested in localizing/Translating TemplateToaster Software in your native language in exchange of a Pro License ? Contact Us