in Wordpress Themes by mikati (780 points)
Hello Lisa,

You may have heard about the recent Woocommerce 3.0 version, a really major update. It has caused a lot of troubles to users. Two days later, version 3.0.1 came out, but still many problems exist. Have you tested that a theme made with TT and exported as Wocommerce compatible theme is really compatible? Thank you,

Katalin

1 Answer

by lifeok (1.4k points)
Woocommerce 3.6 support ?
by mikati (780 points)
Hello,
I don't know about Woocommerce 3.6, my question was about 3.0 and 3.0.1. (See above.) Still waiting for the answer, if TT is compatible with this major new version of Woocommerce.
by lisa-west (34.7k points)
TemplateToaster is  compatible with  all the latest versions of Woocommerce  plugin including Woocommerce 3.0 and 3.0.1. To use a Woocommerce compatible theme from TemplateToaster you please select the 'Woocommerce Compatible' checkbox from the export dialog box while exporting your template.
by dnmpc (600 points)
It is not fully compatible I am have issues with it so this statement is not accurate. here is a link to one of the issues I am having but this did not fix it.

https://createandcode.com/broken-photo-gallery-and-lightbox-after-woocommerce-3-0-upgrade/
by mikati (780 points)
Hello dnmpc,
I agree with you and knew it wasn't compatible - I had the exact same problem as you had and had to insert some codes into the functions.php file to fix it. This is why I asked the question and was surprised by the answer. I think TT should study the latest changes of Woocommerce and adjust their coding accordingly. This is what major theme and plugin developers have been doing because this 3.0.1 version of Woo is so much different from the previous one.
by lifeok (1.4k points)
TemplateToaster version 7, we are going to add design support for Opencart (2.1,2.2,2.3) as well as we are going to update the design experience for higher versions of CMS already there i.e. Magento (1.9 & 2), Prestashop (1.6), Virtuemart (1.1.6) and WooCommerce (2.7).

why you write 2.7 ?????????????????????????????????????????????
by mikati (780 points)
It was a mistake, because Woocommerce 3.0 was previously known as Woo 2.7. (See this: https://woocommerce.wordpress.com/2017/04/04/say-hello-to-woocommerce-3-0-bionic-butterfly/ ) In the meantime, it has already published version 3.0.3. It works fine but only with those plugins and themes which have also been made compatible with this new version in the meantime. There were so many major changes in Woo 3.0 that TT probably needs some time to go through all changes and adjust the programme accordingly. Woocommerce is so popular that TT must take it into consideration.
by lifeok (1.4k points)
Your theme (Oepn1t) contains outdated copies of some WooCommerce template files. These files may need updating to ensure they are compatible with the current version of WooCommerce. You can see which files are affected from the system status page. If in doubt, check with the author of the theme.
by timbrown (280 points)
Hi, mikati-

I'm having that lightbox issue with a TT7 template- as well as WooCommerce telling me that my TT7-generated theme has outdated copies of template files.  I tried the tutorial that's linked with no luck. And while the gallery popup works fine in TT6, the shop page looks like crap and needs a lot of help. It's almost like you're damned if you use TT7 and damned if you use TT6 to create a WooCommerce site. Either way the finished result is not what I want.
Interested in localizing/Translating TemplateToaster Software in your native language in exchange of a Pro License ? Contact Us
...