TT7 7.0.0.14574 does not run on XP or Win7

asked Mar 18 in Issues/Bugs by marcin-sarewicz (190 points)
I have been running TemplateToasters 6 and 7 on Windows XP which is hosted on Linux Virtual Machines, since (unfortunatelly) there is no native Linux version. So far, everything was pefrect but after upgrade of TT6 and TT7 to the newest version TT6 still works fine, while TT7 cannot start at all.

Running TT7 7.0.0.14574 on WinXP gives a message "TemplateToaster has encountered a problem and needs to close.  We are sorry for the inconvenience". Then I tried to run TT7 on Windows 7 Virtual Machine and it is even worse. Program does not start and no message is displayed. TT6 works normally on both WinXP and Win7.

What happened to TT7 that it cannot start on VMs? I have never encountered any problems with running other applications on VM. Is there any way to solve this issue?

5 Answers

answered Apr 2 by templatetoaster (22,980 points)
selected Apr 3 by templatetoaster
 
Best answer
We have resolved the issue in latest build (7.0.0.14727). You can download it from here http://templatetoaster.com/download
answered Mar 19 by paul6552 (480 points)
I have also TT7 running in a win7 virtual machine. It is working like normal. But I do not run TT6 and 7 in the same machine.
commented Mar 25 by marcin-sarewicz (190 points)
Are you sure that you are running the latest TT7? Previous beta versions were ok but now I have tested the latest version on WinXP, Win 7 and Win 10 on different Virtual Machines (Kubuntu and OpenSUSE) and TT7 works only on Windows 10 VM and not on WinXP or Win7.  It does not depend on TT6 installation. Then I must say that TT7 is no longer compatible with Windows XP and Windows 7 at least those, running on Virtual Machines and this is a real obstacle for Linux users.
answered Mar 28 by jarmuzewskiagmail-com (140 points)
Have the same...
answered Mar 28 by lisa-west (26,280 points)

We have generated the issue at our end. We will soon provide an updated build of TemplateToaster version 7 as soon as possible.

answered Mar 29 by lisa-west (26,280 points)

Please install dotnet framework version 4.7.1 from the following link:
https://www.microsoft.com/en-us/download/details.aspx?id=56116

commented Mar 31 by marcin-sarewicz (190 points)
Yes, the newest .NET solved the problem. Now TT7 works on Windows 7 VM. Thank you.
Anyone interested in localization of TemplateToaster v7 in exchange of a Pro License Contact Us
...