in Joomla Templates by johnysnake (120 points)
Hey,

I´ve playing around a bit with Template Toaster and i´m very happy with the options it has to offer. Like being able to add & edit module positions.

But i got an issue when using new created templates containing several added & edited module positions.
When using the template i get an error on the website.


Description:
New added & edited module positions give an error when using the new created template.
When i add a new row with modules, edit the module´s position name to something else and change the size and number of cells, the issue appears.

Like:
Parse error: syntax error, unexpected T_VARIABLE in /home/username/domains/domainname/public_html/subdomainname/templates/blackandwhitetest/index.php on line 55

Reproducibility:
Always

Steps to Reproduce:
1. Create a new template
2. Click "Module Positions"
3. Click "Add/Edit positions"
4. Rename "Module Position 9" to "logo" and press "Ok"
5. Decrease the number of amount of module positions to 2 and resize the "logo" module position to 25%.
6. Add a new row of modules, by increasing the number of rows (RowsEditor) to 2.
(The new row, now contains modules with the names: "Logo11", "Logo12", "Logo13" & "Logo14".)
7. Rename those to "top1", "top2", "top3" & "top4".
8. Export the template. (Zip & (for me) version 1.6, 1.7, 2.5)
9. Upload and install the new template.
10. View the site

http://img208.imageshack.us/img208/5734/issuewithnewmodules.jpg

Please log in or register to answer this question.

Interested in localizing/Translating TemplateToaster Software in your native language in exchange of a Pro License ? Contact Us

---------------------------
Download TemplateToaster v8 Beta (What's New)
...